Scheduled for February 07, 2023 at 4:30 PM – 5:20 PM
Affects
Game Server
Under maintenance from 4:30 PM to 5:20 PM
Completed
February 07, 2023 at 5:20 PMCompleted
February 07, 2023 at 5:20 PMMaintenance has been completed successfully. Ping may seem higher for European players, but we will continue to monitor the server's network performance over the next 14 days. We're not against making changes again.
Update
February 07, 2023 at 5:06 PMIn progress
February 07, 2023 at 5:06 PMWe're almost done, roughly 5-10 mins left!
In progress
February 07, 2023 at 4:30 PMIn progress
February 07, 2023 at 4:30 PMMaintenance is now in progress
Update
February 07, 2023 at 4:30 PMPlanned
February 07, 2023 at 4:30 PMWe are planning to make changes to the server. During this time, you will be unable to connect to the server.
Planned
February 07, 2023 at 4:30 PMPlanned
February 07, 2023 at 4:30 PMMaintenance has been postponed until Monday or Tuesday due to severe weather in Dallas, preventing staff from going in and delays in deliveries for parts.